Renault Twingo Forum - Reply to Topic
Thread: New Twingo Problems Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Renault Twingo Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-03-2018 03:27 PM
RADIO BOOSTER
Cannot stand the radio restart problem!!!!!!!!!

Hi guys.

I bought a used Twingo 2011 (Yahoo edition). First, it was a surprise that the car misses too many things with no excuse, like km/hr indication, temperature, temperature outside etc. While it has a good bluetooth etc. Anyway.

MY ULTIMATE problem is the radio which restarts like 6 times per 15 km. What is going on? Inititally, I thought it was the Bluetooth connection that causes the corruption but not. Cannot do anything and cannot find many similar issues online. You are my only chance. Especially you Turbo, did you fix it? Do you know how?

Thanks a lot
Themis
08-21-2017 04:16 PM
Baliboo12
Quote:
Originally Posted by Baliboo12 View Post
Yes I too have had issues with water ingress. I first noticed that my 66 plate Twingo got very steamed up when the weather was colder but couldn't put my finger on the problem. Now its the school holidays and seemingly the rainy season in the UK I've had complaints from the kids that they're getting wet in the back. On investigation I've found that water is pooling in around the top of the doors just underneath the door seals which would explain why in colder weather I'm getting all steamed up and why the passengers are getting wet!!!

Another fault I've had is that during hot weather there is a loud creaking, banging sound coming from the drivers footwell when breaking and a feeling of vibration through the steering wheel. This only happens in hot weather and has been identified by the dealership as a suspension issue, a large section of which is being replaced on Friday after a two month wait for the parts.

I was initially really happy with my cute little car but after owning two Fiat 500's that never once needed to go to the garage I'm already getting fed up with the inconvenience, especially as I have to insure their courtesy car through my insurance company. I've had part ex quotes against other cars and have lost almost 2000 in 6 months. I'll never buy a French car again!!
Update on the water ingress issue. After another day off the road whilst the garage tested it they've agreed that the rear doors are leaking. I'm currently awaiting new door seals for which they've quoted 7-10 day delivery from the Continent. No replacements are available in the UK which the garage says is due to it being an unusual problem. I'd like to counter that it's so common they've run out!
08-18-2017 10:59 AM
Battery Problems

I have a Twingo Dynaminque S 90 TCE with all the whistles and bells and from day one have had issues with the battery not holding it's charge. Quite often I go to start the car and it's dead. The RAC have told me this is an issue with the battery itself and possibly the Start/Stop which never works. Renault have told me to stop using the climate control and turn the R-Link system as they use power. What is the point of paying for these extra's if I can't use them. They are going to look at it again on Tuesday and yet again want it for the whole day, which means as a community nurse I can't work (trying to get a courtesy car is nigh on impossible) Has anyone else experienced this issue?
08-09-2017 05:48 PM
Baliboo12
Quote:
Originally Posted by Gilksy View Post
Hello all

Bought my Renault Twingo in November for the sum of 12,000 on renaults finance scheme.
The first time it went back was due to after it had rained and you get in and out of the car you would get dripped onto from the door seal.
The rear doors seem to be worst and after a period of driving my car it now steams up due to the water ingress from the doors.
It went back to Renault where there said they found no fault with the car or seals.

After yet another few weeks of getting wet my husband came with me to Renault where he explained his take on the water ingress issue and with the customer service manager and the service guy from the Worcester branch retested the car for water leaks.
After the tests the service manager had a foot long wet line on his right trouser leg and agreed with us that there was an issue possibly even a design fault.

They took all the photos and videos of the leaking water and said they would send all data of to head office to make a descision on the matter'

After a week of waiting the descision was back................................... "The door seal and roof design has no defects that is just the way it has been designed". And we are not going to do anything about it.

Although they didn't use this as a selling point when they were trying to sell it to me.


It's fair to say I will never buy another Renault as I feel I have been brushed aside by them with no consideration.

As of today the car is back in for service due to a misfire on the engine and the stop start has stopped altogether stopping.
I also experience the radio screen turning off and on as other people on here have too.

When I asked them if I could hand the car back they said the trade in value to them is 7174 pounds............yes you heard me right that's a drop of nearly 5,000 for 11 months.
If I except there ridiculous offer I am short on the finance by 2,700 pounds so would have to pay that to hand the car back.
Thank you very much Renault for shafting me.

Any one else getting wet.....?
Yes I too have had issues with water ingress. I first noticed that my 66 plate Twingo got very steamed up when the weather was colder but couldn't put my finger on the problem. Now its the school holidays and seemingly the rainy season in the UK I've had complaints from the kids that they're getting wet in the back. On investigation I've found that water is pooling in around the top of the doors just underneath the door seals which would explain why in colder weather I'm getting all steamed up and why the passengers are getting wet!!!

Another fault I've had is that during hot weather there is a loud creaking, banging sound coming from the drivers footwell when breaking and a feeling of vibration through the steering wheel. This only happens in hot weather and has been identified by the dealership as a suspension issue, a large section of which is being replaced on Friday after a two month wait for the parts.

I was initially really happy with my cute little car but after owning two Fiat 500's that never once needed to go to the garage I'm already getting fed up with the inconvenience, especially as I have to insure their courtesy car through my insurance company. I've had part ex quotes against other cars and have lost almost 2000 in 6 months. I'll never buy a French car again!!
05-19-2017 09:43 AM
LadyBird
Quote:
Originally Posted by djbmc1 View Post
the dealer says they don't see a lot problems with Twingo, so what I don't get is why has my particular car having so many issues and why does it need a bespoke software update ..... surely if the cars contain the same parts and are made in the same factory these faults would be commonplace

I still don't have it back either as of today
I'd like to bet they don't see many problems with Twingo's because they don't sell that many of them!

What was the final outcome for everyone else on this thread? Still got your Twingos and issues or has one or other sorted?
05-01-2017 07:34 PM
swarfendor437
Quote:
Originally Posted by 1393jason View Post
Hi All,

I have a new Twingo (2 months old) has anybody else had any issues with the radio re-starting? as in scrren going blank and then turning back on.

Also does anybody have a noise when the esp light comes on in strong wind? I have spoken to my dealer about this and been told it is normal and is just the system kicking in. I struggle to believe this as it really does not sound good or safe to me.

If anybody can answer any of my questions it would be a massive help.

Cheers
Jason
I've not had the esp problem but the audio has cutout and continual bluetooth disconnection dropping back to radio and having volume up for bluetooth deafening when falls back to radio. What is interesting is that this car was purchased last year (March 2016) and only recently has the radio issue been playing up.

Interesting article here:

http://www.techradar.com/news/car-te...fix-it-1217586

So is the Twingo fitted with DAB or DAB+ ?

I notice on the Scenic you can see Software Version of Audio installed (it does not have DAB) - but no such notice on the Twingo interface - so how do you update the software?

Also curious to know if this workaround works?:

https://together.jolla.com/question/...karound-10716/


Whilst on the topic of faults, does anyone experience the rear windscreen wiper coming on when putting car into reverse gear? This should only happen when windscreen wipers are on and it happens when it is off. Dealer has stated that it is a known issue that can't be resolved due to a 'ghost in the machine'!
02-13-2017 03:34 PM
djbmc1 the dealer says they don't see a lot problems with Twingo, so what I don't get is why has my particular car having so many issues and why does it need a bespoke software update ..... surely if the cars contain the same parts and are made in the same factory these faults would be commonplace

I still don't have it back either as of today
02-03-2017 04:25 AM
TurboTomato Nightmare indeed, it sounds like you've been really unlucky with that particular car.

At least the dealer and Renault UK are stepping up and doing what they can to fix it.
02-02-2017 08:37 AM
djbmc1
nightmare

Touching on some of what has been said so far in the thread

I bought my Twingo Dynamique S TCE in August last year. It is an ex demonstrator & had all the extras fitted - electric roof, climate control, auto lights/ wipers, Sat Nav & Reversing Camera, Heated Seats - & I thought I had really won a watch.

In November started to get the toxic fuel warning light & the car became very jittery when driving. Dealer replaced one of the exhaust sensors and I got the car back. Couple of weeks later same thing again & dealer replaced the other sensor on the exhaust. Car still felt a bit funny to drive at times but in the main was OK.

In December just before Christmas the orange spanner light came on when I was driving and the power seemed to half. I pulled over & phoned the dealer. They asked me to restart the car & if the car was driveable I could bring it in to them for a check & if not call Renault Assistance out, or carry on driving it if it felt ok. I started the car again & the orange light had gone so I continued using the car as normal for a couple of days. As the car was booked in for a service on 30/12 I thought any niggles would be ironed out then.

Come 29th December & the orange light came on again along with the red STOP light. I phoned Renault Assistance and the RAC guy came out & said that the spanner light/ red STOP seemed to be triggered by the air con kicking in. RAC guys laptop diagnostic check highlighted other issues 1 of which was engine speed sensor issue. After testing it with air con on/ off RAC guy asked me to drive to the dealers (1 mile) with the air con off. I did this & made it to the dealers & left it there with them for repair. RAC guy arranged for courtesy car through Enterprise. I got a phone call next day from the dealer advising problem fixed/ service completed & to come & collect car. Dealer advised fault caused by "debris" on a part of the engine (can't remember what part they said). Left the hire car at the dealer for Enterprise to collect and drove home.

I got Renault Customer Services involved at this stage (registered a complaint).

Next day 30th out in the Twingo & orange spanner/ red STOP came on. Called dealer & they asked me to drive to garage again if I could. Switched air con off & made it to the garage ok & phoned Renault Assistance to arrange another courtesy car & was told no courtesy car as I had made it to the garage myself ! Garage advised me I could leave it with them or I could go out & try & replicate the fault & then phone Renault Assistance again so that I could get a courtesy car (which I needed). Managed to replicate the fault (air con off), phoned RAC, drove to garage with them again & got second hire car.

On 5th January dealer contacted me to advise that fault was with main computer/ ecu & that a new part would have to be ordered from France. Part would arrive at garage on 10th January, would be fitted & then car thoroughly tested before being given back to me on Thursday 12th. I got a phone call on Thursday 12th to say car was ready to collect.

I was reluctant to take the car back at that point as I was due to fly out from Edinburgh Airport on Saturday 14th for a weeks holiday & didn't want to break down during the 35 mile journey to the airport, in case I missed my flight. Explained this to Renault Customer Services who agreed to extend courtesy car hire to 14th January & for me to drop car off at Edinburgh Airport Enterprise Office. Advised dealer re this & dealer stated they would test the car every day during the week I was away to make sure no issues & that car would be available to collect from them on 22/1.

Returned to UK on 21/1 and drove home from airport in another courtesy car (3rd) arranged by Renault Customer Services/ Enterprise. Went to dealers to collect car next day as arranged to find that car had broken down again the previous Wednesday during testing and that "something was corrupting the computer" and that a full download from the car would be sent to Renault technical for analysis.

Renault technical have advised the dealer that the car requires a software upgrade (which will take two weeks to write & test) & a full check of the wiring behind the dash. I asked why my car needs the upgrade & not every Twingo and wasn't really given an answer (just a lot of waffle). I am quite concerned about this.

Our current courtesy car hire has now been extended to 6/2.

Loved the Twingo when it was running well but as I say - nightmare.
10-22-2016 05:56 AM
Terrier I've only had mine a month.
Thankfully no issues but I do notice when open the boot when it's been raining that I get a lot of drips coming in.
I've also never known a car to get as dirty door sills!
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Search Tags for this Page

Renault Twingo forum

,
New Twingo forum
,
2015 Twingo forum
,
Twingo 3 forum
,
Twingo III forum
,
2014 Twingo forum